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Student Guide

This exercise manaul and the accompanying software are used in the 8-hour, 
online LabVIEW Machine Vision and Image Processing course.

A. NI Certification
The LabVIEW Machine Vision and Image Processing course is part of a 
series of courses designed to build your proficiency with LabVIEW and help 
you prepare for exams to become an NI Certified LabVIEW Developer and 
NI Certified LabVIEW Architect. The following illustration shows the 
courses that are part of the LabVIEW training series. Refer to 
ni.com/training for more information about NI Certification.

B. Course Description
The LabVIEW Machine Vision and Image Processing course teaches you to 
use National Instruments Vision products to build your machine vision 
application. By the end of this course, you should understand the 
fundamentals of machine vision, the components that make up a machine 
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vision system, and the various resources for locating appropriate cameras, 
lenses, and lighting equipment.

This course assumes that you have a basic knowledge of LabVIEW, 
including the concepts of front panels, block diagrams, While Loops, 
controls, and indicators. The course does not cover LabVIEW basics, so 
National Instruments encourages prior LabVIEW experience to fully 
understand the content of the course. If you are new to LabVIEW, you may 
want to consider taking the LabVIEW Basics I: Introduction course from 
National Instruments before starting this course.

The course is divided into lessons, each covering a topic or a set of topics. 
Each lesson consists of the following parts:

• An introduction that describes what you will learn.

• A discussion of the topics.

• A set of exercises to reinforce the topics presented in the discussion.

In this course you will use an analog image acquisition device, commonly 
called a frame grabber, and the NI Vision Development Module to complete 
the exercises.

C. What You Need to Get Started
When you attend the online course, you will connect to a remote computer 
for you rhands-on exercises. All of the software, hardware and files you 
need are installed on the remote computer.

Before attending the course, check that you can use the remobetr computers 
by running the system check at http://onlinecourses.ni.com/test/.

If you use this exercise manual to complete the exercises using your own 
computer, make sure you have the following items:

❑ NI PCI-1407, NI PCI-1409, NI PCI-1410, or NI PCI-1411 image 
acquisition device

❑ Monochrome analog video camera

❑ BNC cable to connect your camera to your image acquisition device

❑ Power supply

❑ Lens

❑ LabVIEW 8.0 or later
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❑ NI-IMAQ 3.5 or later

❑ NI Vision 8.0 Development Module

❑ The following files:

D. Course Goals
The goals of this course are:

• To teach the fundamentals of building a complete machine vision system

• To introduce the basics of National Instruments image acquisition 
hardware and NI Vision software

• To accelerate the machine vision learning curve

This course does not describe any of the following topics:

• Basic principles of LabVIEW covered in the LabVIEW Basics I: 
Introduction course.

• Every machine vision function or the algorithms behind the NI Vision 
VIs

• How to build a complete machine vision application

The NI-IMAQ and NI Vision libraries contain many VIs that this course 
does not cover due to time constraints. This course covers the VIs that are 
the most commonly used by NI customers. If you have questions about other 
NI-IMAQ and NI Vision VIs, refer to the NI-IMAQ VI Reference Help and 
the NI Vision for LabVIEW VI Reference Help.

E. Course Conventions
The following conventions are used in this course manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to pull 
down the File menu, select the Page Setup item, and select Options from 
the last dialog box.

Filename Description

Exercises Folder for saving VIs and scripts created during 
the course

Solutions Folder containing the solutions to all of the 
course exercises
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This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such as 
menu items and dialog box options. Bold text also denotes parameter names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you enter from the keyboard, 
sections of code, programming examples, and syntax examples. This font 
also is used for the proper names of disk drives, paths, directories, programs, 
subprograms, subroutines, device names, functions, operations, variables, 
filenames, and extensions.
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1
LabVIEW Machine Vision Online 
Course Exercises

Use this manual to complete the exercises for concepts introduced during 
the intructor-led portions of the course.
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Exercise 1 Concept: Measure a Bracket

Goal
Open a solution and familiarize yourself with the NI Vision Assistant 
environment, then see how a Vision Assistant script can be turned into a 
LabVIEW VI.

1. Launch Vision Assistant 8.0 and open the Bracket Inspection solution.

❑ Select Start»All Programs»National Instruments Vision 
Assistant 8.0.

❑ Click Solution Wizard.

Figure 1.  NI Vision Assistant Welcome Screen

2. Select Tutorial»Bracket Inspection and then click Load Solution. 
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Figure 2.  NI Vision Assistant Solution Wizard

3. On the bottom of the screen there are steps recorded in a script. The steps 
comprise an image-processing algorithm created with Vision Assistant. 
Examine how each step is configured.

4. Double-click the step in the script called Pattern Matching 1. This step 
looks for the predefined template pattern, which you can view in the 
Template tab. Notice that the results of the search are shown in the table 
in the middle of the window, and the location of the pattern is 
highlighted by a red square.
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Figure 3.  Pattern Matching Step

5. Click OK.

6. Double-click the Pattern Matching 2 step. Notice that the step matched 
the same pattern on the right side of the bracket. Click OK.

7. Double-click the Edge Detector 1 step. Notice the vertical line drawn 
through the center of the bracket. The step located the top and bottom 
edges of the bracket. In a moment, you will use these edges to find the 
center of the bracket.
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Figure 4.  Edge Detector Step

8. Click OK.

9. Double-click the Caliper 1 step. This step finds the midpoint of the 
two edges that the Edge Detector 1 step found. 

Note A point labeled Caliper 1 has been added at the center of the bracket. The table 
displays the coordinates of Caliper 1.

10. Click OK. 

11. Double-click the Caliper 2 step. This step determines the angle by 
which the bracket is bent between point 1, the center, and point 2.
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Figure 5.  Caliper Step

12. Click OK when you are finished.

13. Create a LabVIEW VI from the script.

❑ Select Tools»Create LabVIEW VI. The LabVIEW VI Creation 
Wizard opens. Use this wizard to create a LabVIEW VI based on this 
script.

❑ Select the version of LabVIEW in which you want to create your VI.

Note If there are multiple versions of LabVIEW installed on the computer, close all 
versions first.

❑ Enter C:\Exercises\LabVIEW Machine Vision\Measure a 
Bracket\Measuring a Bracket.vi as the path to save the VI.

❑ Click Next.

❑ Select Current Script as the script from which to create your VI.
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Figure 6.  LabVIEW VI Creation Wizard

❑ Click Next.

❑ Select Image File as your image source.

Figure 7.  LabVIEW VI Creation Wizard

❑ Click Finish. LabVIEW launches and displays the front panel and 
block diagram of the VI you created in Vision Assistant.
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14. Add the IMAQ Dispose VI (Vision and Motion»Vision Utilities»
Image Management) as the final step to the block diagram. IMAQ 
Dispose will deallocate system memory.

15. On the front panel, right-click the Image Display control and select 
Snapshot.

16. Run the VI and open one of the bracket images from C:\Program 
Files\National Instruments\Vision Assistant 8.0\
Examples\bracket.

17. Examine the generated code.

Challenge
When pattern matching was performed in Vision Assistant, the overlay was 
automatically displayed to help you locate objects. The overlay is not 
displayed by default in the code generated for LabVIEW. Add the code in 
LabVIEW to show overlays for the matched patterns on the image display.

End of Exercise 1
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Exercise 2 Concept: Region of Interest

Goal
Select a region of interest and display it.

Scenario
Regions of interest (ROIs) are frequently used in machine vision 
applications to specify which part of an image is being inspected. For 
instance, it is inefficient and cumbersome to search an entire image for a part 
if you already know a smaller region where the part will exist.

Description
You will enhance a VI you previously created. The code you will add is the 
same regardless of whether you acquire images with a frame grabber or an 
IEEE 1394 camera.

You will create an enhanced block diagram, similar to the following figure.

Figure 1-1.  Block Diagram of Extract Region of Interest VI

1. Launch LabVIEW.

2. Open Snap and Display.vi, located in the C:\Exercises\
LabVIEW Machine Vision\Snap and Display directory. Open 
the Snap and Display.vi block diagram.

3. Add the code to extract a region of interest and display on a second 
Image Display.

❑ Expand the first frame of the sequence.

❑ Add the IMAQ Select Rectangle VI (Vision and Motion»Machine 
Vision»Select Region of Interest»IMAQ Select Rectangle).
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❑ Add the IMAQ Extract VI (Vision and Motion»Vision Utilities»
Image Manipulation»IMAQ Extract).

❑ Unbundle the Rectangle output cluster and build the first four 
elements into an array for the Optional Rectangle input. (Use the 
Build Array function found on the Programming»Array palette.)

❑ Create a destination buffer for the IMAQ Extract VI. Add a new 
IMAQ Create VI and call the input Selection.

❑ Add a second Image Display (Controls»Vision»Image Display) to 
the front panel.

❑ Right-click the Image Display and select Snapshot.

❑ Connect the image and error cluster wires among the new VIs.

❑ Create a constant for the All Images? (No) input of IMAQ Dispose 
and set the constant to TRUE. This will clear both of the image 
buffers from memory when the program completes.

Testing
4. Run the VI.

5. Draw a region of interest in the WindDraw window that opens.

You must use the Rectangle tool to draw your ROI. The Rotated 
Rectangle tool will not work in this exercise.

6. Click OK. Your ROI is displayed in the second Image Display indicator.

7. Save the VI as Extract Region of Interest.vi in the 
C:\Exercises\LabVIEW Machine Vision\Region of 
Interest directory.

End of Exercise 2
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Exercise 3 Pattern Matching VI

Goal
Learn how to use pattern matching to locate objects in an image.

Scenario
Pattern matching is heavily used in semiconductor inspections. Pattern 
matching can help verify part placement and product yield. In this exercise, 
you will locate a text for a jumper on a printed circuit board so the part can 
be placed.

Design
The image processing functions for this VI will be scripted using Vision 
Assistant and the remainder of the code will be written by hand.

Flowchart

Figure 8.  Flowchart of Pattern Matching VI

Description
Open sample images that ship with NI Vision. Create a pattern to find. 
Display the matches. Create a LabVIEW VI that will find the pattern.

1. Launch Vision Assistant.

❑ Click Open Image on the splash screen. If Vision Assistant is 
already open, click File»Open Image.

❑ Navigate to C:\Program Files\National Instruments\
LabVIEW 8.0\examples\Vision\Images\Pcb03. Enable the 
Select All Files checkbox and click Open.

Display
Matches

Look for Instances
of the Pattern
in the Image

Open an 
Image File

Extract a Pattern
to Match from

the Image
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2. Create a pattern template and find it in the image.

❑ Double-click the first image in the image browser.

❑ Select Processing Functions: Machine Vision»Pattern 
Matching.

❑ Click Create Template. The Select a template in the image 
window opens.

❑ Draw a rectangular ROI around the inverted J3.

Figure 9.  Selecting a Template in an Image

❑ Click OK. Vision Assistant prompts you to save the template file.

❑ Save the template to your desktop and name the file 
template.png.

Note A portable network graphic (PNG) file must be used for templates because the 
PNG format allows NI Vision to attach extra data to its header. The template vector map 
is saved in this header.



LabVIEW Machine Vision Online Course Exercises

© National Instruments Corporation 13 LabVIEW Machine Vision and Image Processing Exercises

The selected template opens in the Pattern Matching Setup window. The 
table under the image window describes where each match was found, 
the score of the match (where a score of 1000 represents a perfect 
match), and the angle of rotation of the pattern. A red overlay highlights 
the patterns found in the image.

3. Change the settings and test your pattern matching on different images.

❑ Click the Settings tab and enable the Search for Rotated Patterns 
checkbox.
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Figure 10.  Pattern Matching Setup Window

❑ Click OK.

❑ Click the Image tab in the upper left corner of the Vision Assistant 
window.

❑ Click the Next Image button.

❑ Click the Make Image Active button to make the next image in the 
browser the active image.

❑ Click the Run Once button to run the script on the active image.

❑ Click OK when the script is complete and the pattern is found.

❑ Run the script on each image in the image browser by repeating Step 3.

Notice the score for each match and how the score is affected by changes 
in rotation. If you have an image in which the pattern is not found, try 
lowering the Minimum Score to 500. Change the Minimum Score in the 
Pattern Matching Setup window, on the Settings tab. As you lower the 
score, Vision Assistant reports matches that are less likely to be correct.

4. Create a LabVIEW VI from this Vision Assistant script.

❑ Select Tools»Create LabVIEW VI.

❑ Save your VI as C:\Exercises\LabVIEW Machine 
Vision\Pattern Matching\Pattern Matching.vi.

❑ Click Finish.
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On the block diagram, examine the file path constant wired to the IVA 
Match Pattern Algorithm VI. This control determines the path to the 
template pattern you are matching. Notice that the path is automatically 
populated with the location of the pattern you saved in Vision Assistant.

❑ Add the IMAQ Dispose VI (Vision and Motion»Vision Utilities»
Image Management»IMAQ Dispose) as the final step.

❑ Wire the Error out cluster from the Palette Type property node to the 
Error in cluster of IMAQ Dispose to ensure proper execution order.

❑ Wire the image data type from the Image Out terminal of the IMAQ 
ReadFile VI to the Image In terminal on IMAQ Dispose.

❑ Save the VI. Your VI should look like the following figure.

Figure 11.  Block Diagram of Pattern Matching VI

5. Examine IVA Match Pattern Algorithm.vi.

❑ Double-click IVA Match Pattern Algorithm.vi to open it.

❑ Open the block diagram. Turn on the context help by pressing 
<Ctrl-H>.

❑ Display Frame 0 of the Sequence structure.

The parameters from the Setup Match Parameters cluster are 
unbundled and passed into the IMAQ Setup Match Pattern 2 VI. 
Refer to the context help for more information about this VI.
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❑ Display Frame 1 of the Sequence structure.

Frame 1 performs the pattern matching that was configured in 
Frame 0. The Match Parameters cluster is unbundled and passed into 
the IMAQ Match Pattern 2 VI. The optional rectangle input is used 
to specify the location to search for the pattern.

Testing
6. Display the front panel and run the VI.

❑ Select an image from C:\Program Files\National 
Instruments\LabVIEW 8.0\examples\Vision\Images\
Pcb03.

The template you saved in Step 2 is automatically loaded and found 
in the image.

❑ Check the score from the Matches indicator to see how well the 
located pattern matched the template.

Challenge
7. Add code to interactively select a template when running this VI, rather 

than loading a saved template. Refer to the Exercise 2, Concept: Region 
of Interest, for ideas.

8. Save and close the VI. Keep LabVIEW and Vision Assistant open for the 
next exercise.

End of Exercise 3
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Exercise 4 Locate Bracket Holes VI

Goal
Use morphological functions to analyze an object that could change position 
and shape.

Scenario
Although coordinate systems are useful for tracking objects that change 
position within an image, there are some situations in which using a 
coordinate system is inappropriate. In this example, the shape of a bracket 
must be verified before it is shipped.

You could assign a coordinate system to one of its distinct features, but this 
assumes that the other features of the bracket have the same relative location 
in every image. Instead, you can use morphological functions to find the 
features of the bracket regardless of their location. The features can be 
analyzed to determine the shape of the bracket.

Design
In this exercise you will create a VI that inspects an image of a bracket by 
thresholding the image. Then you will improve the binary image and 
measure the desired particles to determine the straightness of the bracket.
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Flowchart

Figure 12.  Flowchart of Locate Bracket Holes VI

Implementation
1. In Vision Assistant, click File»Open Image.

❑ Browse to C:\Program Files\National Instruments\
Vision Assistant 8.0\Examples\bracket. Select 
Bracket1.jpg and click Open.

2. Threshold the image to define the features of the bracket.

❑ Select Processing Functions: Grayscale»Threshold.

❑ Set the Look For drop-down listbox to Dark Objects.

❑ Set the Maximum to 165.

❑ Click OK.

Generate Code Using Vision Assistant

Find the Center
of Each Hole

Remove Extra
Particles to

Isolate the Holes

Open an Image
of a Bracket

Isolate the 
Background Color

to Find the
Mounting Holes

Generate
a Report

No

Yes Another
Image to
Examine?
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Figure 13.  Thresholding the Bracket

3. Use binary morphological operations to isolate the bracket holes.

❑ Select Processing Functions: Binary»Adv. Morphology.

❑ Select Remove border objects from the list. This option eliminates 
particles that touch the edges of the image.

❑ Click the Connectivity button. Notice the effect that pushing the 
button has on the process.

❑ Click OK to save the step.

4. Fill in the holes of the bracket to create closed particles.

❑ Select Processing Functions: Binary»Adv. Morphology.

❑ Select Fill holes from the list.

❑ Click OK.
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Figure 14.  Filling the Holes of the Bracket

5. Use erosion and dilation to clean up noise in the image without affecting 
the size of the desired particles.

❑ Select Processing Functions: Binary»Basic Morphology.

❑ Select Erode objects from the drop-down listbox at the bottom of 
the screen.

❑ Change the Size parameter to 7 ×  7 to increase the size of the 
structuring element.

❑ Click OK.
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Figure 15.  Using Erosion and Dilation

❑ Select Processing Functions: Binary»Basic Morphology.

❑ Select Dilate objects from the drop-down listbox at the bottom of 
the screen.

❑ Change the Size parameter to 7 ×  7 to increase the size of the 
structuring element.

❑ Click OK.

Note Instead of using Erode objects and Dilate objects, you can try using the Particle 
Filter. Vision Assistant contains more than 50 different Particle Filter parameters that you 
can use to remove unwanted particles from your image. To use the Particle Filter in this 
exercise, select an Area filter and set the minimum value to 1000 and the maximum to 
3000. You can evaluate the difference in processing time with the Performance Meter 
(select Tools»Performance Meter).



LabVIEW Machine Vision Online Course Exercises

LabVIEW Machine Vision and Image Processing Exercises 22 ni.com

6. Now that the particles representing the holes of the bracket have been 
isolated, determine the size and location of the particles in the image.

❑ Select Processing Functions: Binary»Particle Analysis.

Figure 16.  Using Particle Analysis on the Bracket

The table that opens shows an array of values that describe various 
features of the particles in the image. In this exercise, you only need to 
know the area and the location of the centers of the particles.

❑ Click the Select Measurements button to display a list of available 
measurements.

❑ Click the Deselect All Pixel Measurements button to disable the 
measurements.

❑ Check the Center of Mass X, Center of Mass Y, and Area 
measurements.

❑ Click OK.

❑ Click OK in the Particle Analysis Setup to save the step.
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7. Save the script as Locate Bracket Holes.scr in the 
C:\Exercises\LabVIEW Machine Vision\Locate Bracket 
Holes directory.

8. Create a LabVIEW VI based on your Vision Assistant script.

❑ Select Tools»Create LabVIEW VI.

❑ When prompted, select LabVIEW 8.0 as the LabVIEW version 
desired and save the VI as Locate Bracket Holes.vi in the 
C:\Exercises\LabVIEW Machine Vision directory. 

❑ Click Finish. LabVIEW launches and displays a block diagram.

9. Add memory management functions to the VI.

❑ On the front panel, right-click the Image Display control and select 
Snapshot.

❑ Display the block diagram and add the IMAQ Dispose VI to the end 
of code.

❑ Connect the image and error cluster wires to the IMAQ Dispose VI.

❑ Save the VI. Your VI should look like the following figure.

Figure 17.  Block Diagram of Locate Bracket Holes VI

Testing
10. Display the front panel.

11. Run the VI.

12. When prompted, select one of the bracket images.

The analysis results are displayed in an array. You can expand the array 
to view all of the results. The rows represent individual particles. The 
columns represent the X-coordinate, Y-coordinate, and Area of the 
particle respectively.

End of Exercise 4
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A
Using Color Tools

This appendix teaches you the basics of color image representation and how 
to use the color matching, color location, and color pattern matching tools 
in Vision Assistant.

Topics
A. Introduction to Color

B. Using Color Tools
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A. Introduction to Color
Color is the wavelength of the light we receive in our eyes when we look at 
an object. In theory, the color spectrum is infinite. The human eye, however, 
can see only a small portion of this spectrum—the portion that starts at the 
red edge of infrared light (the longest wavelength) and ends at the blue edge 
of ultraviolet light (the shortest wavelength). This continuous spectrum is 
called the visible spectrum.

White light is a combination of all colors. The spectrum of white light is 
continuous and goes from ultraviolet to infrared in a smooth transition. You 
can represent a good approximation of white light by selecting a few 
reference colors and weighting them appropriately. The most common way 
to represent white light is to use three reference components, such as red, 
green, and blue (R, G, and B primaries). You can simulate most colors of the 
visible spectrum using these primaries. For example, video projectors use 
red, green, and blue light generators, and RGB cameras use red, green, and 
blue sensors.

The perception of a color depends on many factors, including the following:

• Hue, which is the perceived dominant color. Hue depends directly on the 
wavelength of a color. 

• Saturation, which is dependent on the amount of white light present in 
a color. Pastels typically have a low saturation while very rich colors 
have a high saturation. For example, pink typically has a red hue but a 
low saturation.

• Luminance, which is the brightness information in the video picture. 
The luminance signal amplitude varies in proportion to the brightness of 
the video signal and corresponds exactly to the monochrome picture.

• Intensity, which is the brightness of a color and is usually expressed as 
light or dark. For example, orange and brown may have the same hue 
and saturation, whereas orange has a greater intensity than brown.

Image Representations
Color images can be represented in several different color spaces. These 
color spaces can contain all color information from the image or they can 
consist of just one aspect of the color information, such as hue or luminance. 
The most common image representation is 32-bit RGB format. In this 
representation, the three 8-bit color planes—red, green, and blue—are 
packed into an array of 32-bit integers. This representation is useful for 
displaying the image on your monitor. The 32-bit integer is organized as

0 RED GREEN BLUE
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where the high-order byte is not used, and blue is the low-order byte.

HSL is a 32-bit color space based on hue, saturation, and luminance. This 
color space is used in image processing applications.

Each color plane can be returned individually. The red, green, or blue plane 
is extracted from the RGB image and represented as an array of 8-bit 
integers. The hue, saturation, luminance, and intensity planes also can be 
returned individually if you want to analyze the image.

B. Using Color Tools

Color Matching
Color matching can be used for applications such as color identification, 
color inspection, color object location and other applications that require the 
comparison of color information to make decisions.

How Color Matching Works
Color matching is performed in two steps. In the first step, the machine 
vision software learns a reference color distribution. In the second step, 
the software compares color information from other images to the reference 
image and returns a score as an indicator of similarity.

Color Identification
Color identification identifies an object by comparing the color information 
in the image of the object to a database of reference colors that correspond 
to predefined object types. The object is assigned a label corresponding to 
the object type with closest reference color in the database. Use color 
matching to first learn the color information of all the predefined object 
types. The color spectrums associated with each of the predefined object 
types become the reference colors. Your machine vision application then 
uses color matching to compare the color information in the image of the 
object to the reference color spectrums. The object receives the label of the 
color spectrum with the highest match score. 

Several industries use color identification. One example is the automotive 
industry, where color identification helps verify the presence of the correct 
components during the assembly process.

Color Inspection
Color inspection detects simple flaws such as missing or misplaced color 
components and defects on the surfaces of color objects. You can use color 
matching for these applications if known regions of interest predefine the 
object or areas to be inspected in the image. You can define these regions or 
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they can be the output of some other machine vision tool, such as pattern 
matching used to locate the components to be inspected.

The layout of the fuses in junction boxes in automotive assemblies is easily 
defined by regions of interest. Color matching determines if all of the fuses 
are present and in the correct locations. Color matching compares the color 
of the fuse in each region to the color that is expected to be in that region.

Learning Color Distribution
The machine vision software learns a color distribution by generating a 
color spectrum. You provide the software with an image or regions in the 
image containing the color information that you want to use as a reference 
in your application. The machine vision software then generates a color 
spectrum based on the information you provide. The color spectrum 
becomes the basis of comparison during the matching phase.

Comparing Color Distributions
During the matching phase, the color spectrum obtained from the target 
image or region is compared to the reference color spectrum taken during 
the learning step. A match score is computed based on the similarity 
between these two color spectrums using the Manhattan distance between 
two vectors. The match score, ranging from 0 to 1,000, defines the similarity 
between the color spectrums. A score of zero represents no similarity 
between the color spectrums, while a score of 1,000 represents a perfect 
match.

Color Location
Use color location to quickly locate known color regions in an image. With 
color location, you create a model or template that represents the colors that 
you are searching. Your machine vision application then searches for the 
model in each acquired image, and calculates a score for each match. The 
score indicates how closely the color information in the model matches the 
color information in the found regions. 

When to Use
Color can simplify a monochrome visual inspection problem by improving 
contrast or separating the object from the background. Color location 
algorithms provide a quick way to locate regions in an image with specific 
colors. 

Use color location when your application has the following characteristics:

• Requires the location and the number of regions in an image with their 
specific color information
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• Relies on the cumulative color information in the region, instead of how 
the colors are arranged in the region

• Does not require the orientation of the region

• Does not require the location with subpixel accuracy

The color location tools in NI Vision measure the similarity between an 
idealized representation of a feature, called a model, and a feature that may 
be present in an image. A feature for color location is defined as a region in 
an image with specific colors.

Color location is useful in many applications. Color location provides your 
application with information about the number of instances and locations of 
the template within an image. Use color location in the following general 
applications—inspection, identification, and sorting.

Inspection
Inspection detects flaws such as missing components, incorrect printing, 
and incorrect fibers on textiles. A common pharmaceutical inspection 
application is inspecting a blister pack for the correct pills. Blister pack 
inspection involves checking that all the pills are of the correct type, which 
is easily performed by checking that all the pills have the same color 
information. Because your task is to determine if there are a fixed number 
of the correct pills in the pack, color location is a very effective tool.

Identification
Identification assigns a label to an object based on its features. In many 
applications, the color-coded identification marks are placed on the objects. 
In these applications, color matching locates the color code and identifies 
the object. In a spring identification application, different types of 
springs are identified by a collection of color marks painted on the coil. 
If you know the different types of color patches that are used to mark the 
springs, color location can find which color marks appear in the image. 
You then can use this information to identify the type of spring.

Sorting
Sorting separates objects based on attributes such as color, size, and shape. 
In many applications, especially in the pharmaceutical and plastic 
industries, objects are sorted according to color, such as pills and plastic 
pellets. Using color templates of the different candies in the image, 
color location quickly locates the positions of the different candies.

What to Expect from a Color Location Tool
In automated machine vision applications, the visual appearance of 
inspected materials or components changes because of factors such as 
orientation of the part, scale changes, and lighting changes. The color 
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location tool maintains its ability to locate the reference patterns despite 
these changes. The color location tool provides accurate results during the 
following common situations: pattern orientation and multiple instances, 
ambient lighting conditions, and blur and noise conditions.

Pattern Orientation and Multiple Instances
A color location tool locates the reference pattern in an image even if the 
pattern in the image is rotated or scaled. When a pattern is rotated or slightly 
scaled in the image, the color location tool can detect the following:

• The pattern in the image

• The position of the pattern in the image

• Multiple instances of the pattern in the image (if applicable)

Because color location only works on the color information of a region and 
does not use any kind of shape information from the template, it does not 
find the angle of the rotation of the match. It only locates the position of a 
region in the image whose size matches a template containing similar color 
information.

Ambient Lighting Conditions
The color location tool finds the reference pattern in an image under 
conditions of uniform changes in the lighting across the image. Color 
location also finds patterns under conditions of non-uniform light changes, 
such as shadows.

Blur and Noise Conditions
Color location finds patterns that have undergone some transformation 
because of blurring or noise. Blurring usually occurs because of incorrect 
focus or depth of field changes.

Color Pattern Matching
Use color pattern matching to quickly locate known reference patterns or 
fiducials in a color image. With color pattern matching, you create a model 
or template that represents the object you are searching for. Your machine 
vision application then searches for the model in each acquired image, 
calculating a score for each match. The score indicates how closely the 
model matches the color pattern found. Use color pattern matching to locate 
reference patterns that are fully described by the color and spatial 
information in the pattern.

Using Color Pattern Matching
Grayscale, or monochrome, pattern matching is a well-established tool for 
alignment, gauging, and inspection applications. In all of these application 
areas, color simplifies a monochrome problem by improving contrast or 
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separation of the object from the background. Color pattern matching 
algorithms provide a quick way to locate objects when color is present.

Use color pattern matching in the following cases:

• The object you want to locate contains color information that is very 
different from the background, and you want to find the location of the 
object in the image very precisely. For these applications, color pattern 
matching provides a more accurate solution than color 
location—because color location does not use shape information during 
the search phase, finding the locations of the matches with pixel 
accuracy is very difficult.

• The object you want to locate has grayscale properties that are very 
difficult to characterize or that are very similar to other objects in the 
search image. In such cases, grayscale pattern matching may not give 
accurate results. If the object has some color information that 
differentiates it from the other objects in the scene, color provides the 
machine vision software with the additional information to locate the 
object.

The color pattern matching tools in NI Vision measure the similarity 
between an idealized representation of a feature, called a template, and the 
feature that may be present in an image. A feature is defined as a specific 
pattern of color pixels in an image.

Color pattern matching is the key to many applications. Color pattern 
matching provides your application with information about the number of 
instances and location of the template within an image. Use color pattern 
matching in the following three general applications: gauging, inspection, 
and alignment.

Gauging
Many gauging applications locate and then measure or gauge the distance 
between objects. Searching and finding a feature is the key processing task 
that determines the success of many gauging applications. If the 
components you want to gauge are uniquely identified by their color, then 
color pattern matching provides a fast way to locate the components.

Inspection
Inspection detects simple flaws, such as missing parts or unreadable 
printing. A common application is inspecting the labels on consumer 
product bottles for printing defects. Because most of the labels are in color, 
color pattern matching is used to locate the labels in the image before a 
detailed inspection of the label is performed.
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Alignment
Alignment determines the position and orientation of a known object by 
locating fiducials. Use the fiducials as points of reference on the object. 
Grayscale pattern matching is sufficient for most applications, but some 
alignment applications require color pattern matching for quick location of 
specific color fiducials.

What to Expect from a Color Pattern Matching Tool
In automated machine vision applications, the visual appearance of 
materials or components under inspection can change due to factors such 
as orientation of the part, scale changes, and lighting changes. The color 
pattern matching tool maintains its ability to locate the reference patterns 
and gives accurate results despite these changes.

Pattern Orientation and Multiple Instances
A color pattern matching tool locates the reference pattern in an image even 
when the pattern in the image is shifted, rotated, or slightly scaled. The color 
pattern matching tool detects the following:

• The pattern in the image

• The position of the pattern in the image

• The orientation of the pattern

• Multiple instances of the pattern in the image (if applicable)

Ambient Lighting Conditions
The color pattern matching tool finds the reference pattern in an image 
under conditions of uniform changes in the lighting across the image. 
Color analysis is more robust when dealing with variations in lighting than 
grayscale processing. Color pattern matching performs better under 
conditions of non-uniform light changes, such as in the presence of 
shadows, than grayscale pattern matching.

Blur and Noise Conditions
Color pattern matching finds patterns that have undergone some 
transformation because of blurring or noise. Blurring usually occurs 
because of incorrect focus or depth of field changes.
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Exercise A-1 Concept: Color Pattern Matching

Goal
Use color pattern matching to search for a defined pattern in an image.

Scenario
Open a color image and learn how to configure a color pattern match in 
Vision Assistant. Lean how to use the color pattern match functionality with 
LabVIEW.

1. Launch Vision Assistant.

❑ Select Open Image. Navigate to the C:\Program Files\
National Instruments\LabVIEW 8.0\examples\
Vision\Images\PCBColor.

❑ Enable the Select all Files checkbox, and then click OK. The images 
now are loaded into the Vision Assistant browser.

❑ Double-click the first image to make the image active.

2. Use Vision Assistant to perform color pattern matching.

❑ Select Processing Functions: Color»Color Pattern Matching. 

❑ Click Create Template.

❑ Draw an ROI around one of the yellow electrical components.

❑ Click OK. 

❑ Save the template pattern to the desktop as colortemplate.png. 
Notice how the template is found in the image.

❑ Click the Settings tab. Set the parameters so that they are the same 
as the parameters in the following illustration.
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Notice that Vision Assistant found more instances of the template.

❑ Click OK. The Color Pattern Matching step is added to your script.

3. Examine the efficiency of the algorithm.

❑ Select Tools»Performance Meter. This meter illustrates how fast 
the script operates under the present conditions.

❑ Click OK.

4. Test the color pattern matching script on all of the images in your 
browser.

❑ Select Tools»Batch Processing. You can see your script with the 
first and only step highlighted. There are several options from this 
view. You can view the panel results and save the results to disk.
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❑ Enable the Open Results Panel checkbox.

Figure A-1.  Batch Processing Window

❑ Click Run.

Vision Assistant applies the script to all twelve images in the 
browser one at a time. If the pattern is found correctly, click OK to 
move on to the next image. If you have an image in which the pattern 
is not found, try lowering the value of Minimum Score. As you 
lower the score, Vision Assistant continues to find the pattern unless 
it is not fully within the image. 

❑ When the batch processing is finished, click OK, and then click 
Return.

5. Generate a LabVIEW VI and examine the VI.

❑ Select Tools»Create LabVIEW VI. Follow the onscreen 
instructions to generate the VI.

❑ Save the VI as Color Pattern Matching.vi in the 
C:\Exercises\LabVIEW Machine Vision directory.

❑ Add a True constant to the All Images? (No) terminal of the IMAQ 
Dispose VI.
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❑ On the front panel, right-click the Image Display control and select 
Snapshot.

❑ Examine the inputs to the IMAQ Setup Match Color Pattern VI and 
the IMAQ Match Color Pattern VI.

6. Run the VI.

❑ At the file prompt, select an image from the C:\Program Files\
National Instruments\LabVIEW 8.0\examples\ 
Vision\Images\PCBColor\ directory.

❑ Modify the Color Pattern Match settings and see how the results 
change.

❑ Save and close the VI when you are finished.

Challenge
You may notice that the located component is not highlighted when the VI 
runs as it was in Vision Assistant. You must add the functionality yourself 
to the block diagram by adding Overlay Matches Position 
Color.vi, which is located in the following directory: C:\National 
Instruments\Program Files\LabVIEW 8.0\examples\Vision\
2. Functions\Color Pattern Matching\Color Pattern 
Matching Example.llb.

End of Exercise A-1
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B
Additional Information and Resources

This appendix contains additional information about National Instruments 
technical support options and NI Vision resources.

National Instruments Technical Support Options
Visit the following sections of the National Instruments Web site at ni.com 
for technical support and professional services.

• Support—Online technical support resources at ni.com/support 
include the following:

– Self-Help Resources—For answers and solutions, visit the 
award-winning National Instruments Web site for software drivers 
and updates, a searchable KnowledgeBase, product manuals, 
step-by-step troubleshooting wizards, thousands of example 
programs, tutorials, application notes, instrument drivers, and so on.

– Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application 
Engineers worldwide in the NI Developer Exchange at 
ni.com/exchange. National Instruments Application Engineers 
make sure every question receives an answer.

For information about other technical support options in your area, 
visit ni.com/services or contact your local office at 
ni.com/contact. 

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. The NI Alliance Partners joins 
system integrators, consultants, and hardware vendors to provide 
comprehensive service and expertise to customers. The program ensures 
qualified, specialized assistance for application and system 
development. To learn more, call your local NI office or visit 
ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit the 
Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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Other National Instruments Training Courses
National Instruments offers several training courses for LabVIEW users. 
These courses continue the training you received here and expand it to other 
areas. Visit ni.com/training to purchase course materials or sign up for 
instructor-led, hands-on courses at locations around the world.

National Instruments Certification
Earning an NI certification acknowledges your expertise in working with 
NI products and technologies. The measurement and automation industry, 
your employer, clients, and peers recognize your NI certification credential 
as a symbol of the skills and knowledge you have gained through 
experience. areas. Visit ni.com/training for more information about the 
NI certification program.

NI Vision Resources
The following documents contain information that you may find helpful:

• NI Vision Concepts Manual—Describes the basic concepts of image 
analysis, image processing, and machine vision. This document also 
contains in-depth discussions about imaging functions for advanced 
users.

• NI Vision for LabVIEW VI Reference Help—Contains reference 
information about NI Vision for LabVIEW palettes and VIs.

• NI Vision Assistant Tutorial—Describes the NI Vision Assistant 
software interface and guides you through creating example image 
processing and machine vision applications.

• NI Vision Assistant Help—Contains descriptions of the NI Vision 
Assistant features and functions and provides instructions for using 
them.

These documents can be downloaded at ni.com/manuals.

The following Web sites contain information that you may find helpful:

• ni.com/vision

• ni.com/camera

• ni.com/labview

• ni.com/dataacquisition

• www.machinevisiononline.org

• www.edmundoptics.com

• www.graftek.com
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Glossary

B

binary image An image in which the pixels have only one of two intensity values. 
Objects in the image usually have a pixel intensity of 1 (or 255), and 
the background has a pixel intensity of 0.

C

CCD Charge Coupled Device. A chip that converts light into electronic 
signals.

closing A dilation followed by an erosion. Closing fills small holes in objects 
and removes boundaries in objects.

color Wavelength of the light that is received by the human eye when looking 
at an object.

connectivity Defines which of the surrounding pixels of a given pixel constitute its 
neighborhood.

connectivity-4 Only pixels adjacent in the horizontal and vertical directions are 
considered neighbors.

connectivity-8 All adjacent pixels are considered neighbors.

D

data line Parallel wires that carry digital signals corresponding to pixel values.

depth of field The maximum object depth that remains in focus.

dilation Increases the size of an object along its boundary and removes tiny 
holes in the object.

E

edge A sharp change or transition in the pixel intensities in an image.

enable lines Lines that indicate when data lines are carrying valid values.

erosion Reduces the size of an object along its boundary and eliminates 
isolated points in the image.
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F

fiducial A reference pattern on a part that helps a machine vision application 
find the location and orientation of the part in an image.

field of view The area of inspection that the camera can acquire.

G

grab Acquisition technique that loops continually on one buffer.

H

histogram Indicates the quantitative distribution of pixels in an image based on 
their pixel intensities.

histograph In LabVIEW, a histogram that can be wired directly into a graph.

HSL Color encoding scheme using hue, saturation, and luminance 
information.

hue Represents the dominant color of a pixel.

I

image mask A binary image that isolates parts of a source image for further 
processing.

interlaced video Acquisition method that splits a video into two images called fields. 
One field contains the odd-numbered lines, while the other contains 
the even-numbered lines. This acquisition method reduces visible 
flicker during screen updates.

L

lens distortion Geometric aberration caused by optical errors in the camera lens.

linear filter An algorithm that calculates the value of a pixel based on its own pixel 
value as well as pixel values of its neighbors. The sum of this 
calculation is divided by the sum of the elements in the matrix to obtain 
a new pixel value.

luminance The brightness information in a video picture.
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M

morphological operations Operations that extract and alter the structure of objects in an image.

N

neighbor A pixel whose value affects the value of a nearby pixel when an image 
is processed. The neighbors of a pixel are usually defined by a kernel 
or a structuring element.

neighborhood operations Operations on a point in an image that take into consideration the 
values of the pixels neighboring that point.

O

open An erosion followed by a dilation. Opening removes small objects and 
smooths boundaries of objects in the image.

P

particle A connected region or grouping of pixels in an image in which all 
pixels have the same intensity level.

pattern matching A machine vision technique that locates regions of a grayscale image 
that match a predefined template.

perspective error Changes in the magnification of an object caused by errors in the 
imaging setup and determined by the distance between the object and 
the lens.

pixel clock Divides the incoming horizontal video line into pixels.

R

rake The rake algorithm computes the best line or circle, given the edge 
coordinates detected. Finds edges along parallel, concentric, or radial 
lines inside a region of interest. 

region of interest An area of the image selected for further processing.

resolution The smallest feature size on your object that the imaging system can 
distinguish.

RGB Color encoding scheme using red, green, and blue color information.
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ring Acquisition technique that continually acquires images using a circular 
buffer of images.

ROI See region of interest.

S

saturation The amount of white added to a pure color. Saturation relates to the 
richness of a color.

sensor resolution The number of columns and rows of CCD pixels in the camera sensor.

sensor size The size of a sensor’s active area.

sequence Acquisition technique that acquires a sequence of images.

snap Acquisition technique that acquires a single frame or field to a buffer.

spatial calibration Assigning physical dimensions to the area of a pixel in an image.

subpixel analysis Finds the location of the edge coordinates in terms of fractions of a 
pixel.

T

tap A group of data lines that carry one pixel each. Also known as a 
channel.

template image A color, shape, or pattern selected for matching in an image. A 
template can be a region selected from a part of an image or an entire 
image.

threshold Separates objects from the background by assigning all pixels whose 
intensities fall within a specified range to the object and assigning the 
rest of the pixels to the background. In the resulting binary image, 
object pixels have a pixel intensity of 1 (or 255) and background pixels 
have a pixel intensity of 0.

W

working distance The distance from the front of the camera lens to the object under 
inspection.




